Technical Support

                    

PDF Documents

In order to view, print, or download the PDF versions of various documents on this website, Adobe Acrobat 5 or later is required. These files may not open properly with older versions of the plug in. Minimize risk when accessing Adobe Acrobat files by using the latest release of Acrobat Reader. Visit http://www.adobe.com/products/reader for more information. 



Hardware and Software Requirements

The www.NCSEAA.edu website is designed to work properly with the following minimum browser versions:

  • Internet Explorer 7 or above  
  • Firefox 3.5 or above 
  • Safari 4.0 or above 

Note: We recommend that the browser version be the most up-to-date version available to provide you with the latest patches and security fixes.

Support for JavaScript, and cookies must be enabled in either browser and can be "turned on" via the Options dialog box in Firefox or the Internet options dialog box in Internet Explorer. The dialog boxes can be accessed from the Tools menu on each browser. In Safari, select Preferences... from the Edit menu to enable these options.